Author Topic: Allballs starter bad after 1 year????  (Read 1799 times)

0 Members and 1 Guest are viewing this topic.

Offline jclark311

  • Full Member
  • Posts: 714
Allballs starter bad after 1 year????
« on: Saturday, June 08, 2013. 09:09:41 PM. »
Running an ultima 113 on a 94 heritage, put in a new allballs starter when I put the motor in last year, battery is a big boar 350cca. I'm reading 12.78 volts off the battery, but the starter won't engage the flywheel. It just makes a spinning noise, like the bendix is bad? i have a push button that bypasses he starter relay, so I now that's not bad. This starter has always struggled to start the motor. Anybody else had problems with allballs starters?

Online ThumperDeuce

  • Site Supporter
  • Full Member
  • *****
  • Posts: 2847
  • Country: 00
Re: Allballs starter bad after 1 year????
« Reply #1 on: Saturday, June 08, 2013. 09:43:12 PM. »
My AllBalls managed to break a tooth off my ring gear.  Have you tried rolling it in gear with the clutch in and then releasing to reposition the ring gear?  I've never had a problem with the starter.
AMBASSADOR TO THE AFRICA REFUGEE AND BENEFICIARIES COMMITTEE HERE IN GHANA

Offline mfalba

  • Site Supporter
  • Full Member
  • *****
  • Posts: 188
  • Country: us
  • Laissez les bons temps rouler
Re: Allballs starter bad after 1 year????
« Reply #2 on: Sunday, June 09, 2013. 05:31:44 AM. »
I've been running an All Balls 1.4 starter on my 98 inch for about 2 years now without any trouble.

Offline Merc63

  • Site Supporter
  • Full Member
  • *****
  • Posts: 1427
  • Country: ca
Re: Allballs starter bad after 1 year????
« Reply #3 on: Sunday, June 09, 2013. 08:29:21 AM. »
Teeth on the starter gear might be worn down and not engaging.
2000 Dyna
126" S&S

Offline koko3052

  • Full Member
  • Posts: 1695
  • Country: ca
Re: Allballs starter bad after 1 year????
« Reply #4 on: Sunday, June 09, 2013. 09:08:57 AM. »
Starter bendix shaft may be slightly bent from kickback or gummed up & not allowing the gear to be "thrown out". :idunno:

Offline Merc63

  • Site Supporter
  • Full Member
  • *****
  • Posts: 1427
  • Country: ca
Re: Allballs starter bad after 1 year????
« Reply #5 on: Sunday, June 09, 2013. 09:34:39 AM. »
I had the shaft break in two from kickback.  Take it off and look.
2000 Dyna
126" S&S

Offline Alien

  • Full Member
  • Posts: 232
Re: Allballs starter bad after 1 year????
« Reply #6 on: Sunday, June 09, 2013. 01:51:59 PM. »
Mine is on a twin cam but my 117 is a bear to start. You will have to take the primary cover off no matter what. When it is off make sure the pinion is coming all the way out and making full contact with the ring gear. If it is,and the starter makes that noise but doesn't turn the ring gear it is your starter gear. I have been through a couple. I have ben running http://www.starterdrives.com/HarleyDrive.htm for a while now with no problems. Good luck

Offline 06roadglide

  • Full Member
  • Posts: 438
  • Country: us
Re: Allballs starter bad after 1 year????
« Reply #7 on: Monday, June 10, 2013. 05:39:07 AM. »
Mine is on a twin cam but my 117 is a bear to start. You will have to take the primary cover off no matter what. When it is off make sure the pinion is coming all the way out and making full contact with the ring gear. If it is,and the starter makes that noise but doesn't turn the ring gear it is your starter gear. I have been through a couple. I have ben running http://www.starterdrives.com/HarleyDrive.htm for a while now with no problems. Good luck


 :agree:  That starter drive is one tough mother. I run a 1.4kw Tech cycles starter on my 117 and it ate the tech cycle drive for breakfast. I disassembled both drives to see how much a difference there was between them because I couldn't believe the advertisement. 

Offline Merc63

  • Site Supporter
  • Full Member
  • *****
  • Posts: 1427
  • Country: ca
Re: Allballs starter bad after 1 year????
« Reply #8 on: Monday, June 10, 2013. 06:54:11 AM. »
Is there anyway to adjust the amount of travel the pinion gear comes out when you hit the starter?
2000 Dyna
126" S&S

Online Buffalo

  • Full Member
  • Posts: 382
  • Country: ca
Re: Allballs starter bad after 1 year????
« Reply #9 on: Monday, June 10, 2013. 12:26:02 PM. »
My 1.6 All Balls starter has been crankin' my S&S 124 since 07. It took teeth off the ring gear when motor wouldn't turn or kicked back. Replaced ring gear with 1-/84 Primo unit, no problems since. fwiw Doug B

Offline Alien

  • Full Member
  • Posts: 232
Re: Allballs starter bad after 1 year????
« Reply #10 on: Monday, June 10, 2013. 02:22:57 PM. »
My 1.6 All Balls starter has been crankin' my S&S 124 since 07. It took teeth off the ring gear when motor wouldn't turn or kicked back. Replaced ring gear with 1-/84 Primo unit, no problems since. fwiw Doug B

I am also running an 84 tooth ring gear.

Online 04 SE DEUCE

  • Site Supporter
  • Full Member
  • *****
  • Posts: 2890
Re: Allballs starter bad after 1 year????
« Reply #11 on: Monday, June 10, 2013. 04:36:37 PM. »
Has the OP left the net? 

Have seen mostly positives on All Balls products and customer service which mirrors my own personal experience.  All Balls has life time warranty to original purchaser and I'm sure replaces starters that are not the root cause of the problem at times.

You didn't list which size starter (kw) you are using

Have you called All Balls?   They go above and beyond to help.

Putting a company name and "bad" in the subject line is probably not a good idea until a proper/solid diagnosis has been done,  JMHO.   Rick 

Offline Sonny S.

  • Full Member
  • Posts: 3343
Re: Allballs starter bad after 1 year????
« Reply #12 on: Monday, June 10, 2013. 04:50:42 PM. »
<<<Have you called All Balls?   They go above and beyond to help.>>>

 :up:  great company and product !!

Offline calif phil

  • Premium Vendor
  • Full Member
  • *****
  • Posts: 1355
  • Country: us
Allballs starter bad after 1 year????
« Reply #13 on: Monday, June 10, 2013. 05:10:03 PM. »
I just ordered a 1.4 kw all balls starter and they are now Chinese.  They used to be made in Canada    I hope it works as well all the other all balls starters I have used.

Offline jclark311

  • Full Member
  • Posts: 714
Re: Allballs starter bad after 1 year????
« Reply #14 on: Monday, June 10, 2013. 05:31:58 PM. »
Sounds like I should call all balls, I bought it from j&p cycles. I took the primary off, checked battery voltage, even put the jump box on the battery, when you engage the starter, the gear doesn't come out of the starter, and engage the ring gear. I put the stock Harley starter back in, and it works fine.

Online ThumperDeuce

  • Site Supporter
  • Full Member
  • *****
  • Posts: 2847
  • Country: 00
Re: Allballs starter bad after 1 year????
« Reply #15 on: Monday, June 10, 2013. 05:53:08 PM. »
Does your starter say made in China anywhere on it?  I am not a fan of Chinese manufacturing.
AMBASSADOR TO THE AFRICA REFUGEE AND BENEFICIARIES COMMITTEE HERE IN GHANA

Offline Sonny S.

  • Full Member
  • Posts: 3343
Re: Allballs starter bad after 1 year????
« Reply #16 on: Thursday, June 13, 2013. 03:54:42 AM. »
Chinese ?? Ya sure ?   :cry:
If so I won't use another....

I know the AB sealed wheel bearings are Chinese...won't use Chinese bearings at all !

Offline calif phil

  • Premium Vendor
  • Full Member
  • *****
  • Posts: 1355
  • Country: us
Allballs starter bad after 1 year????
« Reply #17 on: Thursday, June 13, 2013. 05:10:45 AM. »
Here is a picture of the box it came in

Offline 05FLHTC

  • Full Member
  • Posts: 4529
Re: Allballs starter bad after 1 year????
« Reply #18 on: Thursday, June 13, 2013. 07:36:45 AM. »
I've fought the tooth breakage high CR starter game and IME the biggest handle gain knob you can turn is with the startup timing.  Without debate you need compression releases and they must be used religiously. I also did not help anything when swapped out the final geAring from 3.15 over to 3.37 either.  That placed additional load on the starter

I've been running Altima 1.75 now going into the 5th season and so far I only had to replace the starter gear reused the one off my OEM starter. 

HTH's
Illinois the Corruption Capitol of USA

Offline FSG

  • BrisVegas in Oz
  • Administrator
  • Full Member
  • *****
  • Posts: 11249
  • Country: au
  • BrisVegas
Re: Allballs starter bad after 1 year????
« Reply #19 on: Thursday, June 13, 2013. 10:35:51 AM. »
I just ordered a 1.4 kw all balls starter and they are now Chinese.  They used to be made in Canada    I hope it works as well all the other all balls starters I have used.


There is a difference between Chinese and Taiwanese. 


Offline JohnCA58

  • Full Member
  • Posts: 2158
  • Country: es
Re: Allballs starter bad after 1 year????
« Reply #20 on: Thursday, June 13, 2013. 11:09:10 AM. »
 :hyst:   Phil,  you missed it by a 140 miles (distance from China to Taiwan), anything from either is  :sick:
2000 Road King  HTT120 c.i. 3.68 gearing 3.17 OD kick ass ride

Offline calif phil

  • Premium Vendor
  • Full Member
  • *****
  • Posts: 1355
  • Country: us
Re: Allballs starter bad after 1 year????
« Reply #21 on: Thursday, June 13, 2013. 11:33:55 AM. »
I always lump Taiwan and Chinese stuff together.  Just like John said I think they are both the same garbage.  FSG  thanks for turning the picture around for me. 

Offline JohnCA58

  • Full Member
  • Posts: 2158
  • Country: es
Re: Allballs starter bad after 1 year????
« Reply #22 on: Thursday, June 13, 2013. 12:33:04 PM. »
As for as the All Balls starter,  I am running the 1.7kw in the 120 and has been great for 15K mile.  but I did change my starter ring gear and pinion to the 66 and 9 tooth, the 102t set up didn't last long before that.   lot more meat in the tooth. had it apart last week,  still look like new. they do have a lifetime warranty,  but if they are coming from ROT or ROC,  I think I will rebuild it myself now if and when it is needed.
2000 Road King  HTT120 c.i. 3.68 gearing 3.17 OD kick ass ride

Offline jclark311

  • Full Member
  • Posts: 714
Re: Allballs starter bad after 1 year????
« Reply #23 on: Thursday, June 13, 2013. 08:34:48 PM. »
I just found the paperwork that came with the starter. It says its warranty for life. So I sent power sports industries an email. I'll keep you guys posted on there reply. My guess is they will replace it, as long as I pay for shipping.

Offline jclark311

  • Full Member
  • Posts: 714
Re: Allballs starter bad after 1 year????
« Reply #24 on: Friday, June 21, 2013. 01:52:43 PM. »
I just got off the phone with Allballs, it is warranty for life. Eric told me to ship it to them, and they will repair it. Allballs is in PA.